Could not find invoice
How to fix the "Could not find invoice" error when syncing with QuickBooks Online.
Error Message
Could not find invoice X
Cause
This happens when the connector is trying to find an invoice to check if was paid in QuickBooks Online but the invoice cannot be found. The link between the ServiceBox invoice and the QuickBooks Online invoice has been broken likely because the invoice was deleted from QuickBooks Online.
Resolution
To resolve this, you will have to unlink the invoice in ServiceBox and re-run the sync to re-create it in QuickBooks Online
Need Help?
Contact support by clicking the Help button in the bottom-right corner of your screen when logged in or email us at support@jobboxsoft.com.
Contact support by clicking the Help button in the bottom-right corner of your screen when logged in or email us at support@jobboxsoft.com.