The customer in accounting with name is already linked
Resolve customer name conflicts caused by existing links between ServiceBox and QuickBooks Online.
Error Message
The customer in accounting with the name X is already linked to a customer (named: Y) in ServiceBox.
Cause
This can happen if, on a customer in QuickBooks Online that is already linked to a ServiceBox customer, is changed to have the same name as a different customer in ServiceBox. The system cannot link the new customer to the QuickBooks Online customer because of the existing linkage to the QuickBooks Online customer.
Resolution
To fix this issue, choose one of the following options:
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Option 1: Change the name of the customer in QuickBooks Online back to match the ServiceBox customer they are already linked to (as shown in the error message).
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Option 2: Unlink the ServiceBox customer that the QuickBooks Online customer is currently linked to. This will allow the new ServiceBox customer to be linked instead.
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Option 3: Change the name of the new customer in ServiceBox so that the system can create a separate customer record in QuickBooks Online.
Choose the option that best fits your data structure and sync goals.
Need Help?
Click the Help button in the bottom-right corner of your screen when logged in.
If you're still having trouble, contact our support team at support@jobboxsoft.com.