Unable to find customer in QuickBooks Online for jobsite...
Fix job site sync errors caused by corrupted customer links in QuickBooks Online.
Error Message
Unable to find customer in QuickBooks Online for job site X. You may need to unlink and resync the customer Y.
Cause
This error occurs when the link between a ServiceBox customer and their corresponding record in QuickBooks Online becomes corrupted. The issue is related to the customer that the job site is attached to.
Resolution
To fix this issue:
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Go to the customer profile in ServiceBox that the job site is linked to.
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Unlink the customer from QuickBooks Online.
After unlinking, you can reattempt the sync to restore the connection.
Need Help?
Click the Help button in the bottom-right corner of your screen when logged in.
If you're still having trouble, contact our support team at support@jobboxsoft.com.